SAP Knowledge Base Article - Public

2942631 - SAP JAM - Incorrect reply count after deleting discussion feed

Symptom

When the discussion feed post is deleted from the feed, the reply count is not updated and incorrect

Environment

SAP JAM Collaboration

Reproducing the Issue

  1. Navigate to a group.
  2. From the group menu, select Forums.
  3. Click on a forum topic.
  4. From the Add menu, select Discussion.
  5. Enter a title and body text.
  6. Click Publish.
  7. From the group menu, select Feed.
  8. Add a comment/reply to the feed post created as a result of creating the discussion.
  9. Delete the feed post.
  10. From the group menu, select Forums.
  11. Click the forum topic where you added the feed post.
  12. Notice that the Comment count is now 0. It should reflect the number of replies (1+).
  13. Click on the discussion.
  14. The comment/Comments section disappears.
  15. Click back to the forum topic, and back into the discussion. The discussion comment/reply displays again but the comment count is still 0. It should reflect the number of replies (1+).
  16. Add another comment/reply. Check the comment count. It still displays 0.

Cause

This is a defect

Resolution

Engineering team has made some code changes on correcting the reply count of the discussion list after deleting the discussion feed.

The patch to fix the issue will be released on R544 release date  (July 17, 2020). 

Keywords

delete, removal, discussion, feed, post, comment, reply count, jam, count, zero, incorrect , KBA , LOD-SF-JAM-FED , Feed Issues , Problem

Product

SAP Jam Collaboration all versions