SAP Knowledge Base Article - Preview

2937495 - "Unable to install node: improper constraint" error when deploying HAA application

Symptom

  • Cannot deploy HAA application.
  • In "haa.log", you find:
    • "Unable to install node: improper constraint: >=4.0.0 <9.0.0"
    • "Engines.node (package.json): >=4.0.0 <9.0.0"


Read more...

Environment

  • SAP Web IDE
  • SAP Cloud Platform (Cloud Foundry)
  • SAP Analytics Cloud

Product

SAP Analytics Cloud all versions ; SAP Business Application Studio all versions ; SAP Cloud Platform Business Application Studio all versions ; SAP Cloud Platform Web IDE all versions ; SAP Cloud Platform all versions

Keywords

HAA, SAC, SCP, deploy, improper constraint, error , KBA , CA-WDE-MTA , SAP Web IDE Multi Target App: create, build, deploy , BC-CP-CF-RT , Runtimes Buildpacks , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.