SAP Knowledge Base Article - Public

2935110 - Tab Order is Different from C4C APP Side and Browser Side

Symptom

Tab sequence is changed from browser side on any TI screen.

However, when you login with C4C app, you found that tab sequence is slightly different compared with browser side:

Overview always to be the first tab and Details always to be the second one.

Environment

SAP Cloud for Customer Extended App

Reproducing the Issue

  1. Change tab sequence on overview facet for any TI from browser side.
  2. Login in with C4C app and navigate to corresponding TI.
  3. Find the Overview tab and Details tab is still to be the first and second one.

Cause

It is the designed behavior from app side to fit in displaying for smart devices.

Resolution

Overview tab is always to be the first tab to provide a quick glance to users.

Details tab as an affiliated facet of overview tab. It always to be the second one.

Details tab does not exist at browser side. It is used for displaying more overview information as screen of smart devices are relatively small and it looks bad to display all information in one tab from APP side.

By the way, if overview tab is hidden from browser side, it will be invisible from app side as well. However, details tab is still visible and appears as the second facet as always.

Keywords

Overview Tab, Details Tab, C4C APP, tab sequence , KBA , details tab , overview tab , c4c app , tab sequence , AP-RC-MOB-AND , SAP Hybris Cloud for Customer Extnd App on Android , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , Problem

Product

SAP Cloud for Customer core applications all versions