SAP Knowledge Base Article - Public

2930890 - Purchase Order for Service Agent is Not Correctly Determined in Timesheet

Symptom

A service agent is trying to enter timesheet for project task but the system is determining incorrect purchase order(PO- refers to purchase order).

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Home work center
  2. Select Self-Services Overview
  3. Select "Edit Time Sheet"
  4. Select the project task and enter the time
  5. The system automatically determines a purchase order which is assigned to the service agent but it is not the correct purchase order
  6. You have not created purchase order relevant for the particular service yet but when the service agent entered timesheet, system automatically determines a purchase order relevant for the service agent.

Cause

Determination of default Purchase Order/Item for a time entry follows a sequence of steps. System searches for most specific Purchase Order/Item and if not found, then it goes towards finding less specific Purchase Order/Item.

Generally, Purchase order items are proposed according to priorities as explained below:

  • PO will be defaulted if it is created for the service performer and the PO item is assigned to the selected task and Product.
  • PO will be defaulted if it is created for the service performer and the PO item is assigned to the selected task.
  • PO Will be defaulted if the PO item is assigned to the selected task and Product.

Resolution

You can manually change the purchase order while doing the time recording.

Keywords

time recording for service agent, project purchase order , KBA , purchase order in timesheet , time recording for service agent , AP-PRO , Project Processing , Problem

Product

SAP Business ByDesign all versions