Symptom
In this document we shall discuss the below error when working with Picklist values in the context of OData API Replication:
"XXXX is an invalid picklist value in import file or database for null"
Occasionally, when upserting or replicating picklist/custom picklist values into SuccessFactors (SF), the above error can appear in the OData API Response payload. This can have a negative affect on the replication and can even halt the replication of that user to the system.
Environment
- SuccessFactors (SF)
- BizX
- OData API
Reproducing the Issue
- Ensure the picklist and its value is "upsertable".
- Verify the picklist code (“XXXX”) exists in the picklist (“parentPicklistExample”).
- Perform an OData API Upser into the SF system using the picklist value - e.g:
POST https://apiXX.successfactors.eu/odata/v2/upsert - View error.
Cause
- Assigned login language for the API user is incorrect.
Resolution
- Login Language:
Verify the login language for the API user is en_US. As per our standard documentation it must be en_US.
A new url parameter, fileLocale, is now available for upserts. en_US is currenty supported so in other words, like the
UI and the import engine, OData APIs now support the internationalization of floating decimal points. - Import Check:
Should this not work, please try and IMPORT the file - do not use the API but a manual import. If this also fails, the Picklist needs to be checked with the Employee Central (LOD-SF-EC) Team.
See Also
Keywords
Picklist, error, is an invalid picklist value in import file or database for null, OData, API Login Language, en_US , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , LOD-SF-INT-MDF , Metadata Framework API (MDF) , Problem