SAP Knowledge Base Article - Public

2862169 - User Receiving Email in Different Language - Recruiting Management

Symptom

System users receive e-mails in a different language to what they expect

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Recruiting Management - All Versions

Reproducing the Issue

  1. Trigger an e-mail to a User eg. Status triggered E-mail
  2. The e-mail arrives in a different locale to the user
  3. In the UDF (User Data file), the Locale is configured as expected for that user 

Cause

Multiple users are sharing the same e-mail address in the UDF. As a result the locale selects the default language in 'Manage Recruiting Languages'

KBA.jpg

Resolution

Ensure all users have a unique e-mail address in the UDF. Please note that it does not take into account case sensitivity, i.e. sap.test@test.com and SAP.TEST@TEST.COM would be considered by the system as the same email address.

See Also

2420217 - Recruiter receives emails in wrong language

Keywords

wrong language, locale, language e-mail, users wrong language, case sensitivity, case sensitive, same email address , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions