Symptom
Customer using Analytics, will have a button, 'Manage Reports', under AdHoc Reports.
Clicking on the button will lead to an 'Application Error', stating An inconsistency in the data associated with the page you have requested has been defected and the application is unable to process your request.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors HCM Suite
-
Analytics & Reporting (Ad Hoc, YouCalc, ORD)
-
Adhoc Reports & Report Builder
- Online Report Designer
Reproducing the Issue
- Log in to the instance as the affected user (OR) proxy the affected user
- Navigate to Analytics > Reporting > AdHoc Reports
- Click 'Manage Reports'
- You will receive an 'Application Error'
Cause
'Manage Reports' button is provided to help user navigate from AdHoc Reports to Report Designer directly.
Users who does not have access to 'Report Designer' will receive this error.
Resolution
Provide user permission to access 'Report Designer'.
If permissions are maintained via Analytics, follow Change User Role assignment via the Analytics Admin - User maintenance
- Reload Reports/Analytics tab for the changes to reflect.
If permissions are maintained via RBP, follow Access to Report - Canvas / Online Report Designer - Permission
- RBP changes can take up to 2 hours to reflect. You may alternately refer RBP via Provisioning (only possible for SAP or Partners)
See Also
Keywords
manage, reports, online, report, designer, adhoc, report, application, error, inconsistency, data, associated, permission, permissions, rbp, unable, process, request , KBA , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , LOD-SF-ANA-ORD , Online Report Designer , Problem