Symptom
You notice that a workflow rule in your system failed with the error "E-Mail Delivery Failed, could not reach Recipient Inbox. Check Recipient E-mail ID".
Environment
SAP Sales Cloud
Reproducing the Issue
The issue can happen in several system areas.
To find if a workflow rule failed:
- Go to the Administration work centre.
- Go to the Workflow Rules view.
- Select the relevant rule.
- Click More > Workflow Rule Log.
- Find the failed entry and click 'Failed' to get more information.
- Here you see the error message "E-Mail Delivery Failed, could not reach Recipient Inbox. Check Recipient E-mail ID".
Cause
One possible cause is that the recipient is no longer a valid employee in the system.
Another, is that the e-mail address set as recipient on the rule is not valid.
Resolution
To find information on an employee's validity, follow below steps:
- Go to the Administration work centre.
- Go to the Employees view.
- Search and select the relevant employee.
- In the OWL you can see the 'Valid from' and 'Valid To' dates.
If the e-mail address is not valid, it must be changed on the rule recipient. It is important to mention that for productive tenants, the setting to "Send all e-mails to this address" on Business Configuration is not valid. This means that the system will always try to send the e-mail to the address maintained on the Employee/User/Contact.
Keywords
Failed workflow rule , KBA , LOD-CRM-WKF , Workflow , How To