SAP Knowledge Base Article - Public

2853524 - Initial Verification failed: Error Code [00-02047]. Description: Card Number is required for selected Document - Onboarding 1.0

Symptom

When processing E-Verify the following error is received: Initial Verification failed: Error Code [00-02047]. Description: Card Number is required for selected Document Type Id

Environment

SAP Successfactors Onboarding 1.0

Reproducing the Issue

  1. Got to SAP SuccessFactors HCM > Onboarding;
  2. Open E-Verify activity of affected candidate;
  3. Click Submit Initial Verification;
  4. The following error message is received: Initial Verification failed: Error Code [00-02047]. Description: Card Number is required for selected Document Type Id

Cause

Candidate selected as document type the Employment Authorization Document (Form I-766), but do not provide the card number.

Resolution

In order to submit this activity to E-verify program, it will be necessary include the Form I-766 Card Number (composed by three letters + 10 digits, such as XXX-NNNNNNNNNN) in the New Hire record. For that please find below procedure:

Please reach out to SAP SuccessFactors Cloud Product Support in SAP One Support Launchpad via SAP Expert Chat or Support Incident. In addition, follow the template when creating an incident and provide the necessary information below:

  • Subject: KBA 2853524- Initial Verification failed: Error Code [00-02047]
  • Component: LOD-SF-OBD-EVF

Problem Description:

  1. BizX Company ID 
  • [Insert affected instance]
  1. Affected Hire/Candidate
  • [Insert affected hire/candidate's name]
  • [Insert screenshot of the issue]
  • [Attached a txt file that contains Form I-766 card number and mark as confidential]
  1. Username for Support Access (Read the agreement below)
  • [Insert Username]

May we have your approval for accessing your system environment to continue request? (Reply with your confirmation and username to access, refer to KBA listed below)

With your approval, accessing your system environment you agree for the actions we will take below.

  1. Review the data of affected users and compare it to those users who are working as expected.
  2. Capture screenshots/record screen clips of the issue.
  3. Analyze your system configuration

To know  how to grant support access to SAP Cloud Product Support, please read the full article on 'How to Grant Support Access to SuccessFactors Support Staff' by clicking the reference KBA 2088892.

Keywords

00-02047, Card, Number, Required, Selected, Document, E-verify , KBA , LOD-SF-OBD , Onboarding , LOD-SF-OBD-EVF , e-Verify , Problem

Product

SAP SuccessFactors Onboarding