SAP Knowledge Base Article - Public

2850552 - Error "Bank XX XXXX does not exist" using the API Workforce Person Master Data Replication

Symptom

When creating or updating some employee data using the API WORKFORCEPERSONMASTERDATAREPLI, the following error message appears in the response:

<LogItem><TypeID>211(BF00)</TypeID><SeverityCode>E</SeverityCode><Note>Bank XX XXXX does not exist</Note></LogItem><LogItem><TypeID>022(ECPAO_IN_PROCESSING)</TypeID><SeverityCode>E</SeverityCode><Note>Pernr XXXXXXXX: Infotype 0009, subtype 2 with error</Note></LogItem>

Environment

S/4 HANA Cloud

Reproducing the Issue

  1. Configure the Communication Arrangement SAP_COM_0301.
  2. Use the API WORKFORCEPERSONMASTERDATAREPLI to upload the HR master data.
  3. In the WorkAgreementBankAccountInformation section, specify the Bank Account details:

    bank.jpg

 

  1. Post de API.
  2. See the response:

       response.jpg

Cause

The bank data is not maintained correctly in the system.

Resolution

All the bank information used for the employee master data has to be properly maintained in the Manage Banks tile.

 

Note: if you see the following error in the response: <Note>Enter the bank key</Note> you have to add the <Bank> tag in the payload, taking into account that the Bank information in that section has to be configured in the same tile, Manage Banks.

See Also

2646803 - How to maintain employees data in an S/4HANA Cloud

1FD - Scope Item

Keywords

KBA , CA-HR-S4 , Cross-Application HCM Objects in S/4HANA , How To

Product

SAP S/4HANA Cloud all versions