SAP Knowledge Base Article - Preview

2842595 - Module compiled with Swift 5.0.1 cannot be imported by the Swift 5.1 compiler - SCP for iOS SDK project build error

Symptom

After upgrading the Xcode version from 10.2.1 to 11GA, the build of the sample project generated under SAP Cloud Platform SDK for iOS 3.0 SP02 PL06 would fail with the error message "Module compiled with Swift 5.0.1 cannot be imported by the Swift 5.1 compiler: /Users/pandyas/Destinations/test/SAPCommon.framework/Modules/SAPCommon.swiftmodule/x86_64.swiftmodule"


Read more...

Environment

  • Xcode 11GA
  • SAP Cloud Platform SDK for iOS 3.0 SP02 PL06

Product

SAP BTP SDK for iOS all versions ; SAP HANA Cloud Platform SDK for iOS all versions

Keywords

SCP, iOS, Xcode, SP02 PL06, 10.2.1, 11, Swift, Cannot, Imported , KBA , MOB-SDK-IOS , SAP Cloud Platform SDK for iOS , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.