SAP Knowledge Base Article - Preview

2837088 - upgrade failing without --upgrade-ok option - SAP ASE

Symptom

Trying to upgrade from ASE 15.7 to ASE 16.0 with the configuration parameter "prevent automatic upgrade" set to 1, the ASE failed to boot with the following message:

The current database version '<old version>' is lower than the server's version '<new version>', and the server is configured to require upgrade permission. Boot the server with flag '--upgrade-ok' to permit this boot.


Read more...

Environment

  • SAP Adaptive Server Enterprise 15.7 
  • SAP Adaptive Server Enterprise 16.0

Product

SAP Adaptive Server Enterprise 12.5

Keywords

preupgrade upgrading reboot recycle , KBA , BC-SYB-ASE , Sybase ASE Database Platform (non Business Suite) , How To

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.