Symptom
You have implemented a custom BADI (CTICustomerSearch) to the CTI feature, however when simulating a call in C4C the system displays the message Unknown Caller.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
After implementing a CTICustomerSearch BADI, simulate a call in C4C using the SAP CTI Adapter.
- System displays the message Unknown Caller.
Cause
The CTICustomerSearch have the following parameters supported:
- Activity UUID.
- Business Partner ID.
- ANI.
- DNIS.
- Serial ID.
- Ticket ID.
- External Reference ID.
- Custom Field 1 ... 6.
When implementing a custom search via BADI, the standard search is not performed (only in the CTI standard search multiple callers can be identified). The BADI in this case will not refine the standard search, but will add additional parameters to it instead.
In resume; standard solution search can identify a unique customer, multiple customers, or may not identify any customer at all. The custom search BADI just allows to return a single caller.
Resolution
CTICustomerSearch only allows one Business Partner.
In case you would like the search to be performed for all callers The developer involved in the BADI implementation would need to rewrite the whole standard logic again in his custom BADI (SAP Support does not offer this guidance).
Keywords
CTI; BADI; Unknown Caller; , KBA , LOD-CRM-LA , Live Activity , How To