SAP Knowledge Base Article - Public

2831532 - Error when accessing Interview Central - Recruiting Management

Symptom

Whenever the interviewer accesses Interview Central to rate the candidate, they get an error message:

Error: the rating scale is not properly configured on the job requisition template. Please contact your system administrator for assistance.

errorId=null, timestamp=null, errorMessage=Cannot read property 'length' of undefined, errorName=TypeError

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Login to instance.
  2. Go to Recruiting > Interview Central
  3. Click Rate now and error will be prompted.

Cause

There are 2 possible causes:

  1. The job requisition has no defined rating scale in Assessment Scale.
  2. Mapped rating scale may no longer be valid. It could be deleted or rating name has been updated thus affecting the mapping in the job requisition template.

Resolution

Job Requisition template must be updated with what is currently available in the instance. If the rating scale configuration is still correct but error still occurs, try to save the template to refresh then create a new requisition to validate. Note: Update in rating scale is not dynamic. It will take effect on newly created requisition.

See Also

Assessment Scale Configuration

Rating Scale Creation

2082155 - Interview Central

2749129 - Interviewer able to access application through Interview Central

Keywords

Rating scale error interview central interviewer job requisition assessment , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem

Product

SAP SuccessFactors Recruiting all versions