Symptom
SDK gets closed as soon as we select the CSD for the WSDL.
Environment
SAP Cloud For Customer
SAP Cloud Application Studio
Reproducing the Issue
-
Login to SDK
- Right click on .wsid file
- Click on 'Create Communication Scenario Definition'
- Select SOAP
- Select custom services from the given option
- Click on Next
SDK gets closed.
Cause
This issue happens when there is no binding available in the WSDL file. You can check the same by opening the WSDL file for the affected .wsid file and search for 'binding'. You can see 'no result'.
Resolution
This is known issue and we have a workaround to select the Standard service and create CSD.
Later we can change the services and check custom and uncheck standard from the created CSD to fulfill the requirement.
Below are the example steps :
-
Login to SDK
- Right click on .wsid file
- Click on 'Create Communication Scenario Definition'
- Select SOAP
- Select any standard service from the given option
- Click on Next and finish the CSD creation
- Open craeted CSD and change the service as per the requirement.
Keywords
SDK crashes , Closed , CSD, SOAP , KBA , AP-RC-BDS-WS , ByDesign Studio Web Services , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions