Symptom
When creating job requisitions and selecting its operators, one or more internal users cannot be found in the user search. Sometimes, a few users can be found in the search, but it is still not possible to find some other users following the exact same steps.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management - All versions
Reproducing the Issue
- Access the BizX "Recruiting" tab;
- Click "Create New";
- Click "Create New Job Requisition From Blank Template";
- Click "Find User..." or type the user's name in the field beside it.
Cause
If recruiting groups are linked to job requisitions in the job requisition template, when creating job requisitions with that template, it will only be possible to find users that are members of the referred recruiting group when trying to add them as operators.
Resolution
- Check if there is any recruiting group associated with the job requisition template being used. This can be done using Manage Templates. More information here.
- If so, access the associated recruiting group and edit the users that are part of it, adding the users you are missing when creating the requisition.
See Also
2728359 - How to set a Recruiting Group via Manage Templates - Recruiting Management
Keywords
Unable to find user ; create job requisition ; recruiter , KBA , LOD-SF-RCM , Recruiting Management , Problem