SAP Knowledge Base Article - Public

2816755 - Imported results with more than 14k records are inconsistent while running same query based on Import Data connection to OData service in SAP Analytics Cloud (SAC)

Symptom

  • Imported results with more than 14k records are inconsistent while running same query based on Import Data connection to OData service in SAP Analytics Cloud (SAC)

Environment

  • SAP Analytics Cloud 2019.8.16

Reproducing the Issue

  1. Log on to SAC tenant.
  2. Try to create a new model on Import Data connection to OData service.
    => When the same query runs several times (clean & replace import method), the result differs after each query run if the result set is big (e.g. > 14k records).
    => Some dimension may have different unique members (less then expected) in each run.

Cause

  • The odata server does not order the data SAC requests, which results in the possibility of duplicate data if retrieved in batches.
  • By default, SAC retrieves data in batches of 1000 and larger amounts of data has higher probability of encountering this issue.

Resolution

This issue should be fixed on the odata server side to order the data SAC requests.

Workaround: use the freehand query option to force an orderby ($orderby=[Object]) such that there are no duplicate values if retrieved in batches.

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,  rows, number, members, Odata, missing, lost, unique, different, $skip, $top, $orderby, orderby, freehand, order, batch, duplicate , KBA , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , Problem

Product

SAP Analytics Cloud 1.0