Symptom
- People Profile(PP3) extensions fail to load in the Android app. Or, occasionally, loads after multiple attempts.
- Features in the PP3 extensions do not work properly in the Android app.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Activate the Android app for any SuccessFactors instance that has (custom) extensions set up in People Profile(PP3).
- In the app, navigate to People profile and then the extension section.
- Issues will manifest in various forms
- Failure to load.
- Features not working properly.
Note-> The issue is in the Android app only.
Cause
The People Profile(PP3) rendered within the mobile app is a responsive view of the web feature.
The PP3 webviewer that is currently implemented within the Android app does not support the redirects for activating the single sign on, required to login to the custom extensions in PP3. This, directly or indirectly, causes issues in such extension load and functionality in the app.
Resolution
The current behavior in the Android app concerning PP3 extensions is expected.
But, Mobile team has already logged an Enhancement to fully support these extensions in the Android app. At the moment we do not have an expected fix version for this, but it is being worked upon with appropriate priority.
Keywords
Android,PP3 Extension,Custom Extension,MOB-39258 , KBA , LOD-SF-FWK-MOB , Mobile Application , Product Enhancement