Symptom
In the Items tab of a Sales Order, you observe that midnight is formatted as 00:00 in the Requested Date and 24:00 in the Requested End.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Select the Sales Order ABC (ABC represents your Sales Order ID).
- Click the View All button.
- Navigate to the Items tab.
- Scroll down until you see the fields Requested Date and Requested End
If these fields are set to Midnight, you will see that Requested Date shows that time as 00:00, while Requested End shows it as 24:00.
Cause
This is the intended behaviour for these fields. This is done so there is no confusion regarding representing the start or end of a day.
The Requested Date starts with the beginning of the day and so the time stamp is 00:00, while the Requested End represents the end of the day and so the time stamp 24:00.
Resolution
This is the expected system behaviour.
If you need this functionality urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:
- If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
- If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influencer Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer
Keywords
Sales Order ; Requested Date ; Requested End ; Date ; Time ; 00:00 ; 12:00 , KBA , SRD-CRM-ORD , Orders & Contracts , How To