SAP Knowledge Base Article - Public

2789506 - My Inbox service entry sheet error

Symptom

You are using Flexible workflow for 'Service Entry Sheets'. Documents are flagged for approval and sent to the inbox of the responsible manager. When the approving manager tries to release the 'Service Entry Sheets' from their My Inbox APP, nothing happens, after choosing 'Approve' the document remains in the Inbox. In the system log, error message 'Update was cancelled - workitem is not a user decision' is visible.

Environment

SAP S/4HANA Cloud All Versions

Reproducing the Issue

  1. Create a Service Purchase Order (Manage Purchase Orders) 
  2. Create a Service Entry Sheet (Manage Service Entry Sheets - Lean Services) 
  3. The Service Entry Sheet is marked for approval and sent to the inbox of the approving manager. 
  4. The approving manager accesses 'My Inbox'. 
  5. Approve the Service Entry Sheet, but it remains in the Inbox. 

Cause

Missing Authorisations

Resolution

Approvers of 'Service Entry Sheets' - need a business role containing the authorization objects M_SES_EKG / M_SES_EKO / M_SES_WRK with the activity '*' or '37' (Accept). So to overcome this issue you have to assign business role: SAP_BR_PROJ_MANAGE_COMM to your approving user or assign business catalog SAP_MM_BC_SES_WIAPPROVE_PC to an existing role of the user.

See Also

Documentation

Keywords

SAP_APS_SAP_WFRT_APP,  /IWWRK/BADI_WF_BEFORE_UPD_IB, CL_MM_PUR_SES_APPR_ACTION_BADI, AUTHORITY-CHECK, /iwwrk/mc_wf_rt_ib022, BR_PROJ_MANAGE_COMM. , KBA , MM-PUR-SVC-SES , Service Entry Sheet for Service Procurement , Problem

Product

SAP S/4HANA Cloud all versions