SAP Knowledge Base Article - Public

2788116 - Custom Business Objects UI Fails in Production

Symptom

  • The Go To Generated UI button is greyed out in the Custom Business Objects app in production
  • You have already transported the Custom Catalog Extension into production as well, but while checking this you see:
    • Chips not found for app <Custom Business Object ID> in catalog <Business Catalog ID>
    • Chips not found in group <Business Group ID>, please try to republish
    • Chip not found in catalog <Business Catalog ID>, please try to republish
    • App <Custom Business Object ID> not found in Apps-List for catalog <Business Catalog ID>

Environment

SAP S/4HANA Cloud 1902

Reproducing the Issue

  1. Transport a Custom Business Object and it's corresponding Custom Catalog Extensions into production
  2. Go to the Custom Business Objects app and go to the object
  3. You will not be able to go to the generated ui
  4. Click on Catalog Extensions
  5. Click on Check
  6. At this point the errors will be seen

Cause

The catalog extensions have been transported but have not yet finished publishing

Resolution

  • Wait until the the catalog extensions appear as Published, and then the integrity check should succeed and the Custom Business Object app should work
  • If there are still issues after some time then an incident should be opened under BC-SRV-APS-EXT-BO

See Also

2573814 - "Go To Generated UI" Cannot Be Selected

Keywords

KBA , BC-SRV-APS-EXT-BO , Custom Tables and Nodes , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud 1902