Symptom
You have an outbound replication scenario setup in your SAP Cloud for Customer (C4C) with an external system and you notice failed messages with the below error:
"HTTP Code: 404 ( Not Found )"
When you check the error log of the failed message, the following error details are shown:
[...]
<ERROR_INFO>
<HTTP_ERROR_TEXT>Not Found</HTTP_ERROR_TEXT>
<_--3CSOAP_FAULT_--3E>No faultstring available</_--3CSOAP_FAULT_--3E>
</ERROR_INFO>
[...]
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Administrator work center.
- Navigate to the Web Service Message Monitoring.
- Select the failed message and observe the error text. Then navigate to the View > Error Log and check the error details.
[...]
<ERROR_INFO>
<HTTP_ERROR_TEXT>Not Found</HTTP_ERROR_TEXT>
<_--3CSOAP_FAULT_--3E>No faultstring available</_--3CSOAP_FAULT_--3E>
</ERROR_INFO>
[...]
Cause
- The above error usually occurs when the path or service URL in the communication arrangement is not setup correctly, therefore, the system cannot identify the correct path to reach the middleware.
- It can also happen that the path is correct but the relevant iflow in CPI is not in "Started" status
Resolution
- Verify whether the path and service URL has no additional space and it was correctly setup according to SAP Note 2597086 (- Integration Flow Excel For SAP Hybris Cloud for Customer Integration).
- Go to your CPI monitor, check the status of the iflow.
Keywords
HTTP Code 404, faultstring, not found , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-CRM-INT-CRM , Integration of C4C with CRM , How To