SAP Knowledge Base Article - Preview

2735178 - SMP SDK 3.1 Native SDK build for API level <24 is failing in Android Studio

Symptom

SMP SDK 3.1 Native SDK build for API level lower than 24 is failing in Android Studio with error messages:

Static interface methods are only supported starting with Android N (API Level 24)

Static method com.sap.smp.client.httpc.listeners.IConversationFlowListener$Builder prepareFor() not supported in Android API level less than 24

However according to the SAP Note 2632778 - "SAP Mobile Platform SDK 3.1 Supported Devices Operating Systems" Android 5 (API level 21) is supported.


Read more...

Environment

SAP Mobile Platform (SMP) SDK 3.1 - Native SDK 3.1

Product

SAP Mobile Platform SDK 3.1

Keywords

smp sdk, 3.0, 3.1, native, android, online, build, built, building, fail, fails, failing, api level, java, gradle, build.gradle , KBA , MOB-SDK-ODP , SAP Mobile SDK Odata SDK , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.