SAP Knowledge Base Article - Public

2702011 - Deleting Employee & Contingent Worker data in S/4HANA Cloud

Symptom

There is the requirement to remove some employee or contingent worker data in S/4 HANA Public Cloud system.
For example, an employee was terminated and has to be deleted from the system, or some employee data was loaded in wrong company code and now this has to be adjusted, etc. This KBA article covers some best practices and considerations on this regard.

On this scenario, you may have questions regarding:

  • Deleting an employee
  • Removing a single PERNR (personnel number)
  • Finding the BP id for a user
  • Archiving the BP
  • Deleting the BP

Environment

  • S/4HANA Cloud Public Edition

Cause

Some employee data is incorrect or has to be archived and deleted for other reasons.

Resolution

NOTE: A new KBA has been created which explains the same process in a clearer and more direct way. Please, display KBA 2922814 - How to delete employee data (and Business Partner) in S4HANA Cloud.

First of all, please ensure you review the instructions for archiving employee data which can be found in the section "Data Archiving in Human Resources" from S/4HANA Cloud guide in: https://help.sap.com/viewer/0bebd08dffca45afa67b1f751199afd0/latest/en-US/b27cab8a5ad34b4c8e1bdfc55b0aa57c.html

Later, depending on what needs to be removed, there could be two different scenarios:

  1. Only one PERNR deletion is required AND the employee has other work assignments which should remain valid (other PERNRs), for example in different company codes, etc.

    Only in this case, it would not be necessary to block the business partner and just performing a simple PERNR deletion process following the steps mentioned in the S/4HANA Documentation section "Archiving Employee Data". Afterwards, the other PERNRs existing and the BP will remain unchanged and still valid.
    If once the deletion is triggered, you are getting an error and the PERNR is not deleted please review the authorizations for the roles, as explained below in the additional considerations section.

  2. All the PERNR existing for an employee (whether there is one or several) need to be deleted.

    In this case, the destruction of one or more Personnel numbers of the employee needs to be executed AFTER the corresponding Business Partner has been archived.

    Please refer to documentation listed at the beginning of Resolution section.

    In production environments also, the employee has to be terminated before deletion can take place.
    After the Business Partner was blocked and the PERNR(s) got removed, if the user needs to be deleted or blocked, please proceed with "Maintain Business User" app.

    For more information regarding ILM policies (brief introduction on https://help.sap.com/erp2005_ehp_08/helpdata/en/7f/e188e04fdd462e8ec330bb80efc389/content.htm?no_cache=true) and blocking/deletion of business partner, you can visit:
        1KA scope item for ILM or https://rapid.sap.com/bp/#/browse/scopeitems/1KA
        1J7 Scope item for DPP or https://rapid.sap.com/bp/#/browse/scopeitems/1J7
        How to maintain ILM Policies -> https://help.sap.com/viewer/a630d57fc5004c6383e7a81efee7a8bb/latest/en-US/b0467ee067504fee980d688daff17d0b.html
        2678334 - ILM policy does not exist for business partner
       

    In addition, the HCM Application Name needed to be entered in ILM configuration is BUCP. Please Refer to : https://help.sap.com/viewer/0bebd08dffca45afa67b1f751199afd0/latest/en-US/dd9ca1c121724cfba70a45e92d7f20ca.html
    For more information about ILM policies, we recommend to contact the AP-MD-BP area as CA-HR-S4 does not directly handle this topic.

Some additional considerations:

  • The process of deleting an employee consists in two phases: first requesting the deletion and second performing the actual deletion. Ensure that the two different users who will be performing these tasks both have the Write authorizations set to 'Unrestricted' for their assignment to Business Catalog SAP_HCM_BC_EMP_MAINT_PC using the Maintain Business Role application before proceeding with the deletion process. Otherwise this would fail as this authorization level is required. This write access should be enabled for corresponding roles SAP_BR_DATA_PRIVACY_SPECIALIST and ADMINSTRATOR_HRINFO.
  • If the Business Roles SAP_BR_DATA_PRIVACY_SPECIALIST and ADMINSTRATOR_HRINFO are not appearing in the Maintain Business Roles tile, you may follow any of the below 2 possibilities:
    • Use the Maintain Business Roles App and click on the "Create from Template" button (or the "New" button) and search for the mentioned roles to create them.
    • Use the "Business Role Templates" tile and search for the template for roles "SAP_BR_DATA_PRIVACY_SPECIALIST" and "SAP_BR_ADMINISTRATOR_HRINFO" and then create a Business Role.
  • Public CDS views can be used to display more data for the employees, such as the Business Partner id related to the employee who is going to be deleted. For example, CDS view "Workforce Person Details" can be helpful. For more information, please visit https://help.sap.com/viewer/788fa4c7585e415187e347e904010cee/latest/en-US/f1b5b28b2ecb40af9e1bf52ead527539.html

Keywords

delete, pernr, BP, archiving, block, archived, S/4HANA Cloud , KBA , CA-HR-S4 , Cross-Application HCM Objects in S/4HANA , How To

Product

SAP S/4HANA Cloud all versions