Symptom
When trying to import a quiz, the background job fails and message stating the error says: "Cannot add Question since the Quiz is Published.".
Environment
SAP SuccessFactors Learning Management System (LMS)
Reproducing the Issue
In the LMS admin side, click on:
-
System Admin > Tools > Import Data >
- Select "Import Data" in the Action radio button > From the "Record Type" dropdown, select "Quiz" > Add the file through the "Import File" option > If applicable, select the desired time zone in the "Time Zone ID" > Submit >
- Schedule the Background Job > Finish > Its status shows "Failed" >
- Download the unsuccessful file from the "Import Results" list, "Download" option (System Admin > Tools > Import Data) >
- The "Comment" column, in the "Questions" tab, says "Cannot add Question since the Quiz is Published.".
Cause
The cause, as stated in the "Comment" column, is due to quiz be published.
Resolution
In the LMS admin side, click on:
-
Content > Assessments > Search for the desired quiz and access it >
- Unpublish it clicking on the button from the "Published" column > Confirm clicking on "Yes".
See Also
Keywords
add, upload, quiz, published, failed, background, job , KBA , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ASB , Assessment Builder , Problem
Product
SAP SuccessFactors Learning all versions