Symptom
Product Line Items could be added to Completed Tickets in Fiori but not in HTML Client
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Service work center.
- Go to the Tickets view.
- Open ticket 123 (123 represents the ticket ID).
- Change the status of the ticket to Completed.
- Go to the Items facet.
- You are able to edit and/or add new items.
Cause
Adding of product line items to Completed Ticket has always been possible from the backend, for example PDI, A2X or OData. The Fiori UI was designed to keep it consistent with backend.
For deleting items, the system validates:
- If the Fulfillment Status is In Process or Finished;
- If the external follow up release status code is Released.
Resolution
This is the standard behavior of the system.
If you need this functionality urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by Cloud Service Center . You can contact Cloud Service Center as follows:
1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of SAP Application Development site , choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influencer Site to submit an idea.
Keywords
Ticket,Product Line Items, Item, Service And Repair, Item, Add, Enabled, HTML, Fiori, RUI,Completed, Status , KBA , ticket , status , completed , service and repair , item , add , LOD-CRM-SRP , Service Request Processing , How To