Symptom
Solution activation failed (Deployment Failed) after importing/uploading the solution to the target tenant.
Environment
SAP CLOUD FOR CUSTOMER
SAP BUSINESS BYDESIGN
SAP CLOUD APPLICATION STUDIO
Reproducing the Issue
-
Login to SAP Cloud Application Studio(SDK) for the affected tenant.
- Open PDI Solution YPQRZMNO [YPQRZMNO is a custom PDI solution).
- Upload the Solution.
- Perform solution Activation once the solution upload is successful.
- Solution activation fails with below error messages.
Error Messages :-
Failed to activate items of type References to Customer-Specific Fields
Type of field PXZ does not match
Field PXZ at business object YMN, node Root does not exist
Note :-
PXZ stands for KUT extension field.
YMN stands for business object(custom/extended).
Cause
This error message occurs when you have key user extension fields (eg. PXZ, in this case) in your source tenant but not in the target tenant.
And the same extension field (eg. PXZ) is used in your PDI solution YPQRZMNO.
Resolution
You need to perform content transfer from source to target tenant, so that all the extension feilds are in sync in both the tenants.
Once the content transfer is done, you can activate the solution in the target tenant.
Keywords
SDK, C4C, BYD, Activation Failed, Error when processing class, Errors during activation of solution, Custom Solution , KBA , custom solution , deployment error , BC-DWB-REP-EXT , Extensibility , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Problem