SAP Knowledge Base Article - Public

2680324 - Custom Field not Displayed in UI after Import

Symptom

  • Custom field was transported from QA to Production
  • The field was displayed in an app in QA but the field was not visible in the app in Production after the transport was imported

Environment

  • SAP S/4HANA Cloud 1805 Custom Fields and Logic

Cause

  • The custom field was added to the app using Adapt UI
  • The UI changes were not included in the same software collection as the custom field and were, therefore, not transported from QA to Production

Resolution

  • Ensure that any UI changes made using Adapt UI to add a custom field are included in the same software collection as the custom field and the same transport to Production
  • Note that Custom Fields are not dependent on any UI changes made through Adapt UI to incorporate the field into an App
  • However, UI Changes made through Adapt UI are dependent on any custom fields added

See Also

Custom Field, Adapt, UI, changes, modifications, transport, import, dependency

Keywords

KBA , BC-SRV-APS-EXT-FLD , Custom Fields , Problem

Product

SAP S/4HANA Cloud 1805