SAP Knowledge Base Article - Public

2669969 - Integration Center processes only one record when using "Application / UI" trigger type - Integration Center

Symptom

You created an integration on Integration Center with its Trigger Type set as "Application / UI". When executing the integration, it processes just one record.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
    • Integration Center

Reproducing the Issue

  1.  Create a new integration with Trigger Type = Application / UI

  2.  Here we created an Outbound integration as an example, and we can see that the preview shows many records:

    2018-07-16_09-13-17.png

  3.  However when executing the integration, only one record is written in the generated document:

    2018-07-16_09-16-22.png


NOTE: The same behavior will occur if an Inbound integration is created: only one record is inserted into SF.

Cause

The expected behavior of the integration with Trigger Type "Application / UI" is to process only one single record.

Resolution

The "Application / UI" Trigger Type can only be used properly by Recruiting module related processes.

To get multiple records you should select the other Trigger Types, like the "Scheduled Output CSV File".

See Also

Another related KBA 2491521 - Integration Center - User Assistance Documentation link

Integration Center Guide

Keywords

Integration return one record, integration center one record, APP/UI integration one record, one record only, integration center run now 1 record, integration center preview different from run now, app, ui, Application / UI, triggering, one user, no filter, , KBA , LOD-SF-INT-INC , Integration Center , LOD-SF-INT , Integrations , How To

Product

SAP SuccessFactors HXM Suite all versions