Symptom
You want to know the details of the Visits which were deleted for Contact Jane Doe (where Jane Doe is Contact name) but you cannot find it in the Changes facet of Jane Doe .
Environment
SAP Hybris Cloud For Customer.
Reproducing the Issue
-
Go to Customers workcenter.
-
Go to Contacts view.
-
Open Contact Jane Doe .
-
Go to Changes facet.
The records for deleted Visits is unavailable.
Cause
In a Business Partner(Contacts,Accounts,Individual Customers,etc) Changes facet you only see Business Partner changes. Transactional data changes (i.e. Visit deletions) cannot be seen there.
Resolution
To see the transactional data changes follow the below steps:
- Go to Administrator workcenter.
- Go to General Settings view.
- Click on Deleted Data hyperlink.
- Here select the Business Object as Visits and click on Go.
You will be able to see records of deleted Visits.
Keywords
Visit,Contact,Account,Employees,Deleted Data , KBA , delete , remove , visit , deleted data , business partner , LOD-CRM-ACC , Account , LOD-CRM-ACT-VST , Visit Planning , Problem