SAP Knowledge Base Article - Preview

2666433 - Data Services Designer Error When Connecting a 9i Data Source: Connections to this server version are no longer supported

Symptom

  • Unable to create a new Oracle 9i datastore in SAP Data Services Designer
  • The following warning is thrown:
    WARNING: Cannot establish database connections. 'ODBC call <SQLDriverConnect> to connect database <DataStoreName> failed with error: <ODBC call <SQLDriverConnect> for data source <DataStoreName> failed: <[Oracle][ODBC][Ora] ORA-03134: Connections to this server version are no longer supported.>. Notify Customer Support.>. Use the ODBCDriverSelector (Windows) or DSConnectionManager.sh (UNIX) utility in LINK_DIR/bin to configure the correct version of the driver. If the problem still exists after selecting the correct version of the driver, notify Customer Support.' (BODI-1111341)


Read more...

Environment

  • SAP Data Services 4.2 SP10 Designer
  • Oracle 11g as the Data Services repository
  • Oracle 9i as a data source
  • Oracle 11g & 12c Client on Designer Machine

Product

SAP Data Services 4.2

Keywords

ODBC, ORA, instant client, upgrade, BODS , KBA , EIM-DS-DEP , Deployment, Installation, Upgrade , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.