SAP Knowledge Base Article - Public

2665889 - Cannot Define Workflow Rule Condition with Extension Field.

Symptom

You want to define a Workflow Rule with an extension field, but not able to find the specific field in the drop-down list under Define Conditions step.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator work center.
  2. Go to Workflow Rules work center view.
  3. Create a new Workflow Rule.
  4. Enter a Business Object and set the Timing accordingly.
  5. Navigate to step 2 Define Conditions and Click Add Group.
  6. Cannot find the specific field in the drop-down list.

Cause

The Field Type Value of the extension field might be defined as URL.

Workflow condition evaluation for field of type cannot support for URI (URL link, such as email address).

Resolution

You could change the Field Type of the extension field to other value, such as TEXT.

Then it should come in drop down list while condition evaluation.

Keywords

Workflow Rule;Define Conditions;Extension Field; , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions