Symptom
You are unable to Open E-mail Attachments in Ticket Interaction, document Format Changed to RFC 822
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
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Go to Service Work Center
- Go To Tickets View
- Open any ticket
- Navigate to Interactions tab
- Open an attachment with the format .msg
- Format of the attachment changed to .rfc822
Cause
Issue is due to incorrect configuration of MIME type in the system
Resolution
-
Go to ‘Business Configuration’ Work Center
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Click on ‘Overview’
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In the drop-down menu select ‘All configuration elements’
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Click on the Find field and enter the text ‘Allowed MIME Types for Document Upload’
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Select the line shown by the search
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Click on ‘Change Immediately’ button
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In the next screen, search for ‘Mime Type: message/rfc822’
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Select the record and in the File Extension section, uncheck the default flag against msg
-
Change the following entry: eml default = 'X'
Keywords
RFC 822, MSG, Ticket, attachment, interactions , KBA , rfc 822 , msg , LOD-CRM-SC-EML , Email , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions