SAP Knowledge Base Article - Public

2662257 - Translation issue when importing Legacy Picklist

Symptom

All of the picklists have question marks instead of the russian characters when exporting the picklist file.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Navigate to Admin Center > Picklists Management > 'Export all Picklists > Character Coding: Western European > Submit;
  2. Wait 30 seconds or so and 'Hit Refresh' until 'Download Export' Appears;
  3. Open the zip file > Download and open the csv file;
  4. Scroll across to the column named 'ru_RU' > note several fields in this colum have translations as '??????????????'

Cause

The Picklists need to be saved in the correct encoding file, which is the UTF-8.

Resolution

To resolve this problem, you need to follow the below steps:

  1. Export the picklist data file, open with notepad++, update some question marks in Russian to correct words, change encoding to UTF-8 and save with UTF-8.
  2. Import the file back using UTF-8 encoding, choose the local file and set picklist option to No(Are all the Pick Lists new?)
  3. Change language to Russian, check the modified element.
  4. Export the file back using UTF-8 encoding and open with UTF-8 encoding.

Keywords

Language, picklist, encoding, UTF-8, translation, issue, error, import , KBA , LOD-SF-PLT-PCK , Picklist Management Issue , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-PLT-LAN , Translations & Text Replacements , Problem

Product

SAP SuccessFactors HXM Suite all versions