SAP Knowledge Base Article - Public

2652158 - Error: Missing channel e-mail address in recipient fields (TO or CC)

Symptom

You receive error message in the Web Service Message Monitoring: "Missing channel e-mail address in recipient fields (TO or CC)".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the General settings view.
  3. Under System Administration, click hyperlink Web Service Message Monitoring.
  4. Select relevant error message id.

Error: "Missing channel e-mail address in recipient fields (TO or CC)".

Cause

This error could indicate one of two things:

  • The incoming e-mail didn't have any direct recipients, it is all the e-mail recipients were in BCC.
  • This admin settings of the e-mail channel to which the email was sent is either incorrect or incomplete.

In both cases, the system would reject the incoming e-mail with the error: "Missing channel e-mail address in recipient fields (TO or CC)".

Resolution

  • If it is the first case, the message should be canceled.
  • If it is the second case, you need to maintain the channel and then the message can be restarted. 

Keywords

Web service message monitoring, e-mail, TO, CC, channel, missing, recipient , KBA , csg_q , incoming error message , webservice message monitoring , servicerequestingin , recipient , e-mail , email , missing , channel , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SRP-INT , Ticket Interactions , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions