SAP Knowledge Base Article - Preview

2632240 - Connection to system REPOSITORY using REPOSITORY lost after enabling SAML 2.0 support

Symptom

You have enabled Security Assertion Markup Language (SAML) version 2.0 on the whole PI/PO system . After that you are able to access Integration Directory, however when you try to open some object, you get the error as below:

Connection to system REPOSITORY using application REPOSITORY lost. Detailed information: Error accessing "http://<host>:<port>/rep/query/int?container=any" with user "PIDIR<SID>". Response code is 302, response message is "Found"

Once you disable SAML 2.0, the error will disappear.


Read more...

Environment

  • SAP NetWeaver 7.3
  • SAP enhancement package 1 for SAP NetWeaver 7.3
  • SAP NetWeaver 7.4
  • SAP NetWeaver 7.5

Product

SAP NetWeaver 7.3 ; SAP NetWeaver 7.4 ; SAP NetWeaver 7.5 ; SAP enhancement package 1 for SAP NetWeaver 7.3

Keywords

Single Sign-On, SSO, SAML, SSL handshake, Integration Directory, Integration Builder, Repository, ESR, Response code, 302, Process Integration 7.30, PI 7.30, Process Integration 7.31, PI 7.31, Process Orchestration 7.4, PI 7.4, PO 7.4, Process Orchestration 7.5, PI 7.5, PO 7.5, AEX , KBA , BC-XI-IBC , Integration Builder - Configuration , BC-JAS-SEC-SML , JAVA SAML 1.1 and 2.0 , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.