SAP Knowledge Base Article - Public

2625815 - Workflow reports are not working - Misconfiguration and RBP restriction (WorkflowsRBP)

Symptom

  • Workflow related tables are not fetching any records in Advanced Reporting 
  • Workflow related data are not appearing in Advanced Reporting reports even after changing the Date option to Show All/ Current Date.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite
    • Online Report Designer > Advanced Reporting
    • Report Centre > Report - Canvas > Advanced Reporting

Reproducing the Issue

Home > Analytics > Analytics > Advanced Reporting > Workflow > Fetch all columns from "Workflow Wf Request" Table > No data

OR

Home > Analytics > Analytics > Advanced Reporting > Workflow > "Workflow Emp Wf Request" (fetch all columns from this table) > No data

For instances with Report Centre:
New Canvas Report > Advanced Reporting > Workflow > "Workflow Emp Wf Request" (fetch all columns from this table) > No data

 

Cause

This is because of missing permissions.

Resolution

To know what are the missing permissions for particular user, we have a permission check available under check Tool which you can.

1. Go to Admin Center -> Check Tool

2. Under Check Tool, Select Reporting -> Configuration Issues -> Permissions and settings related to workflows have been set up correctly for Analytics.

Check tool.PNG

3. Run the Check and see Result column

  • If No issues - User has all the permission to get data from workflow tables.
  • 1 issue found: User has some missing permission. Click on "1 issue found" link and it will show you the steps to all permission configuration"

result.PNG

Below is the above "Proposed Solution" steps explained in details:

1.The feature 'Add Permission: View Completed Workflows' has to be enabled in Admin Center → Platform Feature Settings


Admin_Center.jpg

2. Refresh RBP from Provisioning under Company Settings.

3. Once the feature is enabled, workflow approvers, participants or admin users who want to view the completed, rejected or canceled workflow requests must be granted the RBP permission "View Completed Workflows"

RBP.jpg

4. (Optional) To control the data access period of one completed workflow request, admin user can set the period by going to Admin Center → Manage Permission Role → select a role → click Edit Granting → Data Access Period Settings → Completed Workflows

See Also

2443076 - Workflow reports are not fetching information on Advanced Reporting - RBP restrictions

Keywords

work, flow, report, data, missing, Advanced, Realms, Manage, Request, View, Completed, Platform, Feature, Settings, Permission, RBP, WorkflowsRBP, issue, error, blank, sync, out, centre, canvas , KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-ANA-RBP , Roles & Permissions , Problem

Product

SAP SuccessFactors HXM Suite all versions