Symptom
The field "User System ID" is appearing when we navigate to a contingent worker -> Take Action -> Edit Work Order Information. It does not appear when we view the portlet or edit it from Edit (clock) option.
Environment
Employee Center -> Contingent Workforce
Reproducing the Issue
-
Search for a contingent worker
- Take Action -> Edit Work Order Information
- Notice the field "USer System ID".
Cause
The field is appearing because this is cinfgured with Visibility = "Yes" in Manage Configuration UI for the portlet. By design, the field will not appear when viewing Work Order.
Resolution
Change the visibility to "No" to resolve the issue. This is explained the the implementation guide "Contingent Workforce Management" (https://help.sap.com/doc/36ce69d1c7c64d4d86366818ee2802ee/1711/en-US/SF_EC_CWM_Impl.pdf) under the section Configuring the UI Definition for Work Orders.
Keywords
userSysId, UI, Configuration, CWM, CWF , KBA , LOD-SF-EC-CWF , Contingent Workforce , Problem