Symptom
You are trying to create an extension field in Custom screen and on save getting error Field Creation Failed.
Reproducing the Issue
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Go to Customers work center as an example.
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Click on Individual Customer view.
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Open any Customer.
- Navigate to Custom facet which you have created.
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Click on Adapt -> Edit Master Layout.
- Try creating extension field in any of pane.
- On save, you will get an error though there is extensibility anchor.
Cause
Custom UI's are not meant to provide extensibility anchor. Custom extensions fields to such UI's are meant to add via SDK and not via KUT.
Resolution
There are 2 types of anchors
- Extensibility Anchor -> which enables creation of Extension fields
- Personalization anchors -> which enables all other changes like add(not create) a field to UI, hide a field and all other changes possible in adaptation and personalization modes.
For PDI created UIs, extensibility anchors are not permitted, since key user should not be able to create fields on such UI and the underlying BO.
For PDI created UIs, if a personalization anchor is added, then other changes such as hide / unhide, drag and drop will work.
Keywords
KBA , field creation failed , extensibility anchor , personalization anchors , extension field in custom ui , extension field in custom ec , section group anchors , BC-DWB-REP-EXT , Extensibility , Problem