Symptom
Employees facing below error while applying Time sheet on 1st Oct 2017 2.00AM to 2.59AM (day light saving). "Remote Exception: RuntimeException; nested exception is: org.joda.time.IllegalFieldValueException: Value 2 for hourOfDay is not supported: Illegal instant due to time zone offset transition (daylight savings time 'gap'): 2017-10-01T02:39:53.970 (Australia/Sydney)"
Instance/Company ID is not in the country where day light saving is applied.
For Internal Teams:
Or you might get this application error: Logs from server would say org.joda.time.IllegalFieldValueException (errorId=..., fingerprint=348b31e65d3b0f6031a181be2427ffe8c01c98ca, timestamp=2017-11-22T14:46:54.504+1100): Value 2 for hourOfDay is not supported: Illegal instant due to time zone offset transition (daylight savings time 'gap'): 2017-10-01T02:46:54.491 (Australia/Sydney)
Environment
SuccessFactors
Employee Central 2.0
Time Sheet
Reproducing the Issue
Step 1:Go to Time sheet of an employee
Step 2:Enter any value from 2.00AM to 2.59AM in Start time or End Time
Step 3: As soon as you enter the time falling in range of 2:00 AM until 2:59AM the system throws error. "Value 2 for hourOfDay is not supported"
Cause
System was taking the server timezone instead of the employee's locale or country.
Resolution
Two patch fix has been applied on 1711 release to fix this issue. Last fix was applied on 2nd December.
Keywords
Value 2 for hourOfDay is not supported, time sheet error, daylight savings time 'gap' , KBA , value 2 for hourofday is not supported , time sheet error , daylight savings time 'gap' , employee central , LOD-SF-EC-TMS , Time Sheet , Problem