Symptom
When trying to register for a Scheduled offering in LMS using the Mobile App, user is not seeing the Register option and getting an error message "Not available in the mobile app. Please complete this action in a computer browser."
Environment
SAP SuccessFactors Learning
Learning Management System (LMS)
Reproducing the Issue
Step 1: Launch the SF mobile APP
Step 2: Go to Learning
Step 3: Click My Assignments
Step 4: Click on the schedule offering item
Step 5: Click the Offerings
Step 6: No register link appear in the app, warning appears "Not available in the mobile app. Please complete this action in a computer browser."
Cause
Approval is associated with the schedule offering but the approver is not determined,in this case the registration is possible only through web and not mobile.
Resolution
This is an expected behavior.
This particular message appears when the approval is associated with the schedule offering but the approver is not determined.In other words, when the user doesn't have a supervisor or any specific approver is not defined in approval process.
In this case the registration is possible only through web and not mobile. Hence the user gets the message that the action is only possible via browser on a computer.
Keywords
Not available in the mobile app. Please complete this action in a computer browser, not able to register for Scheduled offering in mobile app,using mobile app,scheduled offering register button/option not available , KBA , LOD-SF-LMS-MOB , Mobile Application Issues Only , Problem