SAP Knowledge Base Article - Public

2544054 - Custom Application Tile Not Available in SAP S/4HANA Cloud

Symptom

A custom app generated from a custom business object is not available in the Launchpad

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Create a custom business object
  2. Use the business object to create a custom application 
  3. Transport the extensions to production
  4. Once the application has been imported into product the app is not visible in the Launchpad

Cause

  • The custom application may not have been added to a business catalog
  • The user may not have the correct roles assigned to biew the business catalog
  • The custom application or custom business object may have been transported to production, but the custom catalog extension may not have been transported

Resolution

  1. Ensure the application has been added to a business catalog using the Custom Catalog Extensions app
    • If the tile appears in the QA environment, but not in production, then the custom catalog extension may not have been transported
    • Make sure that both the custom tile and the custom catalog extension are both transported
  2. Ensure the user attempting to view the app has the correct role assigned to view this business catalog
  3. For more details review the video in the Generating Custom Applications

Keywords

business object custom analytical query application generate ui transport extensibility catalog , KBA , BC-SRV-APS-EXT-BO , Custom Tables and Nodes , Problem

Product

SAP S/4HANA Cloud 1708