SAP Knowledge Base Article - Public

2538899 - LMS catalog error "Unable to connect to JAM to retrieve search results"

Symptom

The BizX/JAM integration within LMS is set up correctly. The user has the proper authorizations to access JAM. However, at the moment a search is performed in the catalog, a pop-up error is thrown. The error is related to JAM.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Access BizX;
  2. Go to Learning as an user;
  3. In the catalog box, try to search for any item and click "Ok" or hit "Enter";
  4. The search page will load and a pop-up error will be thrown with the following message:

    JAM Error.jpg

Cause

The affected user did not accept the Terms and Conditions of JAM. If JAM is not integrated with the environment, it is enabled in LMS side.

Resolution

The user needs to access JAM and accept the Terms and Conditions. With it, if the integrations are correct and if the user has the proper authorizations, the error will not happen anymore.

To check the relevant integrations, please see:

KBA 2323363 - JAM Integration in LMS Knowledge Support and Tips

  • For Advanced editions of SAP Jam the main integration steps required are: 
  1. jamIntegrationEnabled", ensure that it is set to "true" (see section 2 part II of above KBA)
  2. In Learning Administration > System Administration > Configuration > System Configuration > BIZX settings, please check if there is an extra forward slash (/) in the end of the baseURL= property (e.g. baseURL=https://performancemanager.successfactors.eu/). If yes, please remove the forward slash of the end of the baseURL and apply the changes.
  3. 'Enable API' is enabled in SAP Jam 'Admin' 'Feature Management' section. 
  4. updating the “successFactorsCubeTreeBaseURL” according to the correct server mapping. Please see section 2 part III of above KBA

For Advanced Plus or Enterprise editions of SAP Jam please see KBA 2266004 - SAP Jam integration with LMS

In case JAM is not suposed to be integrated with LMS, disable it in LMS settings:

  1. Log as an Admin;
  2. Navigate to System Admin > Configuration > System Configuration;
  3. Find and open LMS_ADMIN in edit mode;
  4. Search for "jamIntegrationEnabled" using your browser's search functionality;
  5. Change 'true' to 'false' and save the changes.

See Also

2323363 - JAM Integration in LMS Knowledge Support and Tips
2497535 - Catalog search error HttpClientErrorException: 403 Forbidden
2161834 - Unable to Connect to Jam. Please Verify your Jam Integration setting and connectivity whilst adding Jam Groups to an item in LMS
2458958 - Token error with catalog search bar
2266004 - SAP Jam integration with LMS

Keywords

Unable to connect to JAM to retrieve search results. Please try again. If the issue persists, please contact your system administrator, JAM, search, catalog, item, error, learning, jamIntegrationEnabled , KBA , LOD-SF-LMS-JAM , Integration with SAP Jam , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-INT , Integrations with BizX , LOD-SF-LMS-CAT , Catalog , Problem

Product

SAP SuccessFactors Learning all versions