Symptom
- How to clear the MDF cache
- One or more of these symptoms might be occurring:
- MDF objects disappeared from the instance
- MDF objects are not showing up in the Configure Object Definition page but you still can see them in Configure People Profile (or other part of the system)
- Different browsers show different list of MDF objects
- Picklist Centre is empty, error in browser console log "Entity PickListUIV2 is not found. Please contact your system administrator."
Environment
- SAP SuccessFactors HXM Suite
- OData API
- Metadata Framework (MDF)
- SAP SuccessFactors Employee Central
Cause
Inconsistencies can sometimes occur when changes are made to MDF objects in the following scenarios:
- Uploading the Corporate or Succession Data Model xml in Provisioning
- Changing the Corporate or Succession Data Model in Admin Center via Manage Business Configuration
- Changing an Object Definition
Resolution
If the changes made to the MDF Objects are not correctly reflected in the instance, clearing the MDF cache is recommended.
For customers:
To clear the Metadata Cache go to:
- Admin Center
- OData API Metadata Refresh and Export
- Refresh Metadata Cache*
*If this is not a visible option in Admin Center, then you will need to permission it via RBP. The tool is found under the permission category Manage Integration Tools.
For Partners and Customer Support:
To clear the MDF Cache via Provisioning go to:
- Provisioning
- Under "MDF Cache Tool" click "Clear Cache" link
- Click "Click to clear cache" button
See Also
Keywords
Success Factors , SF , EC , MDF Cache Tool , Refresh Metadata Cache , Could not find property with name, odata, api, integration, clear cache , KBA , LOD-SF-MDF-OBJ , Object Definition & Field Related Issues , LOD-SF-INT , Integrations , LOD-SF-EC-MDF , MDF & EC2MDF Migration , LOD-SF-INT-ODATA , OData API Framework , How To