Symptom
The Referrer is not getting an email when a referral candidate is submitted and moved through the pipeline. The Candidate receives an email but the referrer does not.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
Prerequisites:
- Employee referral is correctly set up in the Production system as per all the requirements.
- In the recruiting email triggers, all the 3 triggers related to Employee referral should be enabled:
- Employee Referral Program Candidate added to General pool notification
- Employee Referral Program Candidate referred to a job requisition (new candidate)
- Employee Referral Program Candidate referred to a job requisition (existing candidate) - In the Applicant status configuration, the referrer email is set up properly.
Refer a Candidate to a job requisition, notice that the candidate will receive emails related to referral but the referrer will not.
Cause
The candidate is technically a non-applicant until they actually apply to the requisition. Until they apply, they will be considered a forwarded candidate and the referrer will not receive the email notification when the candidate is moved through the pipeline.
Resolution
While the referred candidate remains a non-applicant, changes to their applicant status will not trigger any email to the referrer.
This is an expected behaviour.
Keywords
Referee, E-mail, E mail, Edit Applicant Status Configuration, , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , How To