SAP Knowledge Base Article - Public

2509490 - Error: 'Internal Error.' when attempting to Logon to BusinessObjects Enterprise from Crystal Reports

Symptom

  • Error: Internal Error.
  • Unable to connect to the BusinessObjects Repository.
  • When attempting to logon to SAP BusinessObjects Enterprise from Crystal Reports designer, it fails with the error: "Internal Error."

Environment

  • SAP Crystal Reports 2011
  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016
           
  • SAP Crystal Server 2011
  • SAP Crystal Server 2013
  • SAP Crystal Server 2016
          
  • SAP BusinessObjects Business Intelligence Platform 4.0
  • SAP BusinessObjects Business Intelligence Platform 4.1
  • SAP BusinessObjects Business Intelligence Platform 4.2

Reproducing the Issue

  1. Open Crystal Reports.
  2. Under the menu "File", select "Open"
  3. In the "Open" window, select "Enterprise", and enter the SAP BusinessObjects BI Server information and user credentials.
       
    It then fails to connect, and generates the error: "Internal Error."
      
        
     Internal Error 01.png

Cause

  • The version of Crystal Reports, does not match the version of Crystal Server, or of SAP BusinessObjects Business Intelligence Platform, it attempts to connect to.
             
    For example, if you are using
         - Crystal Reports 2016 with Support Pack 03
         - SAP BusinessObjects Business Intelligence Platform 4.2 with Support Pack 04
           
    and attempt to connect from Crystal Reports to the SAP BusinessObjects BI Platform, it will fail with the internal error message, since they are at different product update. One is using Support Pack 03, and the other one is using Support Pack 04

Resolution

  • Update Crystal Reports to match the version and Support Pack of the SAP BusinessObjects Business Intelligence Platform or SAP Crystal Server you are using.
       
    1. Confirm the Version and Support Pack of Crystal Reports, by selecting "About Crystal Reports..." under the menu "Help"
                
    2. Confirm the Version and Support Pack of Crystal Server, or SAP BusinessObjects Business Intelligence platform, you want to connect to.
           
    3. Review the list of the version of Crystal Reports that correspond to the version of the server it can connect to:
        
      SAP Crystal Reports SAP Crystal Server SAP BusinessObjects Business Intelligence platform
      2011 2011 4.0
      2013 2013 4.1
      2016 2016 4.2

               
    4. If the version of Crystal Reports does not correspond to version of the server it connects to, install the version of Crystal Reports that match the version of SAP Crystal Server, or SAP BusinessObjects Business Intelligence platform you are using.
           
    5. Update Crystal Reports to match the Support Pack of the SAP BusinessObjects Business Intelligence Platform or SAP Crystal Server you are using.       
        
      For examples:
        
      If you are using:   
      - Crystal Reports 2016 with Support Pack 03
      - SAP BusinessObjects Business Intelligence Platform 4.2 with Support Pack 04
         
      Then the solution is:
      - To update Crystal Reports 2016 to Support Pack 04, to match the version of the SAP BI 4.2 Server.
        
        
      If you are using:
      - Crystal Reports 2016 with Support Pack 04
      - Crystal Server 2016 with Support Pack 03
        
      Then the solution is:
      - To update Crystal Server 2016 to Support Pack 04, to match the version of Crystal Reports 2016 used; or
      - To uninstall Crystal Reports 2016 - Support Pack 04, and install Crystal Reports 2016 with Support Pack 03,
         so both Crystal Server and Crystal Reports are at the same Support Pack level.

Keywords

CR, Internal Error, product Mismatch, lower version, higher version, CRDesigner, login, BI, repository , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2013 ; SAP Crystal Reports 2016