SAP Knowledge Base Article - Public

2449702 - Alert Notification is not being received by all the CC Roles

Symptom

EC Alert Notification is not being received to all the emails in CC

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

Successfactors - Employee Central

Reproducing the Issue

Alert is configured but the emails configured under the CC are not getting email notification.

Cause

  1. Single Recipient is configured in Provisioning. This will send all of the email notifications to the email that is configured in the Single Recipient Email.
  2. The CC Role user does not have an email maintained in Basic User Data
  3. The CC Role configured is not supported for the Alert Type (if it is MDF Alerts)

Resolution

CC - An email is sent to notify the recipient of workflow completion. Once a workflow is completed the named users in the CC role will be sent a notification email of the workflow completion. Refer to:2080108 - Workflow Role Types - Employee Central

1. Single Recipient

  1. log in to Provisioning (If you do not have access, please check with your partner or raise an incident with support)
  2. Navigate to Company Settings
  3. Disable Single Recipient -> Save

 Please refer to 2087890 - Top Reasons Why Email Notifications are Not Sent or Received. Basic Troubleshooting - HXM Suite

2. User does not have valid Email Address maintained

  1. Go to Admin Center > Employee Export > Export Users
  2. Check that the user in question has a valid email address in the "email" column 

3. The CC Role configured is not supported for the Alert Type (if it is MDF Alerts)

If this is regarding MDF alerts, only certain Roles are supported for CC Role. Please refer to article 2532558 - How To Configure MDF Alerts and Notifications for MDF Objects

FAQ - Additional Information

Q) Where can I get Guide?

A) Guide: Employee Central Workflows: Implementation and Administration

Chapter: Setting Up Batch Reminders for Stalled Workflows with a Recurring Job

See Also

  • 2087440 - Disabling Email Notifications For One or More Users for an Instance
  • 2087890 - Top Reasons Why Email Notifications are Not Sent or Received. Basic Troubleshooting - HXM Suite 
  • 2358563 - Workflow Email not being sent to all cc recipients
  • 2446500 - How is the Recipients local Determined for Workflow Emails and Alerts and Notifications
  • 2632511 - Workflow Participant Receives two Email Notifications for the Same Workflow
  • 2087739 - Single Sender and Single Recipient | How They Work and How to Set Them Up
  • 2080108 - Workflow Role Types - Employee Central 

Keywords

Alerts, Notification, Workflow, Email, Single Recipient, Recipient. ec, mdf, change Email Notification setting, CC , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem

Product

SAP SuccessFactors HXM Suite all versions