Symptom
Customer reports that specific users are unable to access the CPM module.
Environment
- SAP SuccessFactors HCM Core All Versions
- Continuous Performance Management
Reproducing the Issue
- When attempting to access users with CPM permissions are unable to do so
- Even with all permissions correctly enabled, users will find themselves unable to access CPM
Cause
Essentially what has occurred is that "Employee Export" permission has been permission on ANY role the user may have and excluded the Granted User from having the permission access to him/herself, once this exclude self for "Employee Export" is turned on, the User query odata will respect this configuration and there for the user will not be able to access themselves in CPM.
Resolution
The solution is as follows:
- Go to User Role Search
- Input access user in question
- Permission Category: Manage User
- Permission: Employee Export
- Search for roles
Once results are generated Search for Permission Group that user is part of and remove "exclude Granted User from having the permission access to him/herself"
Keywords
CPM Loading Employee Export , KBA , LOD-SF-CPM-ADM , Admin Center, RBP. Permissions and Settings , Problem