SAP Knowledge Base Article - Public

2445065 - Legacy Direct Deposit Portlet cannot be seen in employee files upgraded to People Profile (PP3)

Symptom

Direct deposit HRIS element has disappeared from employees interface.

Instance has not upgraded direct deposit to new Payment Information V3

Environment

SuccessFactors with Employee Central module

Legacy direct deposit portlet

People Profile 3 (PP3)

Cause

Direct Deposit portlet missing in employee files is because of upgrade made from Version 12 User Interface to People Profile (PP3). Though the data for Direct Deposit is intact, it cannot be seen in the UI because People Profile is using blocks instead of portlets used in V12 version. You can revert back the version to Version 12 via the Upgrade Center if you want Direct Deposit to be displayed.

As per Employee Central Master Handbook (https://help.sap.com/viewer/b14dd15ca58f43e0856184a740a4b212/latest/en-US/e3d792435ef94c979fb9e6a3738b581c.html ), the old HRIS-based Direct Deposit or Payment Information (handled by the HRIS elements directDeposit and paymentInfo) is no longer supported. You must use the new MDF-based Payment Information. However, you can continue to use the old HRIS-based Direct Deposit or Payment Information, but we highly recommend that you migrate to the new MDF-based Payment Information.

Resolution

You should migrate to the new MDF-based Payment Information.

Is not possible to revert back to the old UI version.

For more information about the new MDF-based Payment Information, see the Setting up MDF-based Payment Information section or the Configuring Payment Information admin guide.

Keywords

Legacy Direct Deposit Portlet Payment information People Profile Employee files , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem

Product

SAP SuccessFactors HCM Core 1702