SAP Knowledge Base Article - Public

2443076 - Workflow reports are not fetching information on Advanced Reporting - RBP restrictions

Symptom

  • User is unable to access workflow requests through Admin Center > Manage Workflow Requests
  • User is not getting any data while running EC Standard Workflow reports
  • No data appears while fetching any workflow related tables in advanced reporting reports

Environment

  • SAP SuccessFactors HCM Suite
    • Online Report Designer > Advanced Reporting
    • Report Center > Report - Canvas > Advanced Reporting

Reproducing the Issue

  1. Go to Advance Reporting and select "Workflow" from drop-down;
  2. Select all columns from "Workflow Emp Wf Request" table;
  3. No data appears;
  • This behavior also happens to any EC Standard Workflow Related reports;

Cause

User has not been granted access to workflow data in RBP

Resolution

  • User must have "Manage Workflow Request" RBP permission in order to run / view data in workflow related advance report. To grant the above permission, please find the RBP role where this permission needs to be granted then navigate to below steps:
  1. Go to Admin Center
  2. Manage Permission Role
  3. Permission > Administrator Permissions
  4. Manage Workflows > Manage Workflow Requests
  5. Done
  6. Save Changes

Important: Please wait for at least 5-6 hours to refresh the RBP permission granted above and then try running the workflow report.

Workflow_Permission.PNG

 

NOTE:

Please check the following article for other causes and corresponding fixes:
2625815 - Workflow reports are not working - Misconfiguration and RBP restriction

Keywords

Manage, Workflow, Request, report, missing, data, rbp, working, error, issue, canvas, Online, Designer, Advanced, Center, permission, role , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , Problem

Product

SAP SuccessFactors HXM Core all versions